Insights reports are loading slow or time out

Incident Report for NewStore Inc

Resolved

This incident has been resolved.
Posted Nov 29, 2025 - 03:43 UTC

Monitoring

We have seen significant performance improvements for Insights reports and are monitoreing the situation.
Posted Nov 29, 2025 - 02:41 UTC

Investigating

We have received reports that some Insights reports are loading very slowly or time out and show a blank page.
We are currently investigating together with our BI service provider and will update here when we have more information.
Posted Nov 29, 2025 - 02:03 UTC
This incident affected: Business Areas (Insights).