Service Degradation for third-party Shipping API
Incident Report for NewStore Inc
Resolved
EasyPost has notified that the incident with their FedEx API is now resolved. Please re-try to print labels if your order was affected. If you continue to receive errors printing a label, please contact NewStore Support.
Posted Jul 21, 2021 - 21:55 UTC
Monitoring
From the easypost status page: FedEx is responding to some rate and label API calls. Users should retry their requests, though performance may still be degraded. Our engineers continue to monitor the situation.

https://www.easypoststatus.com/
Posted Jul 21, 2021 - 20:13 UTC
Investigating
Easypost is currently having increased error rates, https://www.easypoststatus.com/. We have identified that this is affecting some integrations, and are currently investigating the full impact that this is having to our services. We will continue to update you with additional information here as soon as it is available.
Posted Jul 21, 2021 - 19:18 UTC
This incident affected: Business areas (Shipping).