Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 27, 2025 - 05:00 UTC
Scheduled
NewStore will be performing a maintenance on the payment infrastructure to improve resiliency and mitigate issues with the recent event stream degradation. This is scheduled to take place over one and a half hours starting on August 27th, 2025 at 05:00 until 06:30 UTC.
Maintenance Window: 27th August from 05:00 UTC to 06:30 UTC
Impact Description: - Retailers in the Associate App: Delays can be observed in payment processing and occasional failures that might require the Associate retrying an operation. - NOM (NewStore Order Management): No down time is expected, but delays can be observed in payment statuses and/or cash management reports. - Integrations: Delays can be observed in outgoing events that are related to/triggered through payments delivered via the external webhooks: - Event-stream webhooks - Payment provider webhooks
Posted Aug 25, 2025 - 17:04 UTC
This scheduled maintenance affected: NewStore Platform and Business areas (Payments).