Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 09, 2026 - 08:00 UTC
Scheduled
We will be performing scheduled maintenance on **March 9** to improve system reliability and performance.
Maintenance Window - March 9, 08:00–09:00 UTC
During this window, there may be a brief service interruption of up to approximately 5 minutes. This interruption could occur at any time within the maintenance window.
Potential Impact During the brief interruption: - Some API requests may temporarily return **5xx errors** - Services related to **stock information and availability** may be briefly unavailable - Systems depending on these APIs may experience short delays until services resume
Affected Areas The following functionality may be impacted during the brief interruption:
- Stock and Availability -- Stock levels in NewStore Omnichannel Manager (NOM) -- Routing -- Web orders -- Product swap -- BOPIS shipping options -- Imports
- Integrations -- Integrations relying on the affected APIs may receive temporary **5xx responses**. We recommend implementing **retry logic with a short delay** for failed requests.
Recovery All services are expected to **recover automatically and immediately after the brief interruption**. We appreciate your understanding as we perform this maintenance to improve platform performance and reliability.
Posted Mar 06, 2026 - 18:48 UTC
This scheduled maintenance affected: NewStore Platform and Business Areas (Fulfillment, Routing, Inventory Management, Omnichannel Manager).