We are not seeing any further impact from this incident, so we are updating it to resolved.
If you are still encountering issues, please contact NewStore Support.
Our team will conduct a root cause analysis and provide an incident report in the near future.
Posted Mar 24, 2026 - 18:01 UTC
Monitoring
We identified and resolved an issue that caused some order and fulfillment endpoints to return 404 errors which impacted in-store returns, order injection and various other fulfillment API endpoints.
We ask that you please resume normal operations and retry any operations that returned an error or 404 such as order injection or in-store returns.
If you are still encountering issues, please contact NewStore Support.
Our team will continue to monitor and provide further updates.
Posted Mar 24, 2026 - 16:10 UTC
Identified
We have identified elevated error rates across several endpoints and are working to resolve the issue as quickly as possible.
We will share further updates as soon as more information becomes available.
Posted Mar 24, 2026 - 15:27 UTC
This incident affected: Business Areas (Returns & Exchanges, Fulfillment).