UPS API partial outage affecting booking shipping labels

Incident Report for NewStore Inc

Resolved

Easypost has implemented a fix and they are monitoring on their end.
As we have not seen any further errors for the last 3 hours in our monitoring, we are setting this incident to resolved.
Posted Dec 11, 2025 - 23:04 UTC

Update

Easypost updated their incident.
The issue has been identified and a fix is being implemented on their end.
Our monitoring has not shown any new errors for more than 2 hours now.
Posted Dec 11, 2025 - 22:33 UTC

Update

We are still awaiting for an official update from Easypost, and so we continue to monitor errors on our end.

We will continue to update you as this Incident progresses.
Posted Dec 11, 2025 - 22:00 UTC

Monitoring

Although we have not had any official update from Easypost, we are monitoring errors on our end and can see that they have dropped significantly since this was first reported.

We will continue to update you as this Incident progresses.
Posted Dec 11, 2025 - 20:18 UTC

Investigating

Easypost has alerted us that there is currently a UPS API outage that is affecting our retailers.

You may see errors trying to book shipping labels when choosing UPS as a shipping option and asking you to try again later.

We would advise your stores to choose another shipping option if enabled for your business until this is resolved.

We will update again once we receive further information. You may also subscribe to the Easypost incident as well: https://www.easypoststatus.com/incidents/005d0wylry05
Posted Dec 11, 2025 - 19:02 UTC
This incident affected: Business Areas (Fulfillment) and Third-Party Integrations (EasyPost API).