Adyen Payment Degraded Performance in US

Incident Report for NewStore Inc

Resolved

Adyen has confirmed a resolve for this issue, see below:

We can confirm that the issue resulting in a service degradation for our cloud terminal api has been fully resolved since 16:43 CEST.
Our engineering team remains engaged and is urgently working to resolve the situation.
We will provide a new update if required.

Please follow updates on our status page (https://status.adyen.com/).
Posted Aug 21, 2025 - 14:51 UTC

Identified

Adyen has identified the issue, see below update:

We have identified an issue affecting payment processing over cloud terminal api for a subset of terminals connecting to the United States starting at 15:45 CEST.
Our engineering team has been engaged and is urgently working to resolve the situation.

Please follow updates on our status page (https://status.adyen.com/).
Posted Aug 21, 2025 - 14:49 UTC

Update

We are continuing to investigate this issue.
Posted Aug 21, 2025 - 14:43 UTC

Investigating

Adyen has reported an in person payment processing issue in the United States, see statement from Adyen team:

We are currently experiencing severely degraded performance for merchants connecting to our United States endpoints since 15:45 CEST.
Our technical teams are actively working on urgently resolve this issue.

See below for more information on their status page
https://status.adyen.com/
Posted Aug 21, 2025 - 14:43 UTC
This incident affected: Business areas (Checkout, Payments, Returns & Exchanges, Payment Service Provider).