Degraded EasyPost FedEx shipping performance

Incident Report for NewStore Inc

Resolved

EasyPost has marked this issue as resolved. Please reference this page for any further information: https://www.easypoststatus.com/
Posted Nov 25, 2023 - 19:35 UTC

Investigating

EasyPost has reposted an incident with FedEx shipping. Please see https://www.easypoststatus.com/ for details.

This may cause issues with booking deliveries and creating shipping labels. In response to this, deliveries will be retried automatically, but can also be retried from within the Associate App.
Posted Nov 25, 2023 - 17:05 UTC
This incident affected: Business areas (Shipping).