The incident is now resolved, and all affected NewStore services have been fully restored at this point.
All of the payments for affected orders should be recovered now; however, if you do notice any orders that you believe are still unresolved and affected from this timeframe, please open a Support ticket. Our team will investigate and treat them with priority to resolve.
We apologize for the impact and confusion this may have caused your associates and customers. The team will continue to monitor and fully investigate the root cause.
Posted May 14, 2025 - 13:01 UTC
Monitoring
Between 10:06 UTC and 10:38 UTC, we experienced a degradation in our payment services, which may have caused failures in cash transactions and delays in order placement. The services have been fully recovered, and all services are now operating normally. We are currently reviewing and addressing any potentially impacted orders.
Thank you for your patience.
Posted May 14, 2025 - 11:00 UTC
This incident affected: Business areas (Payments).