NOM Insights Reporting Outage

Incident Report for NewStore Inc

Resolved

This incident has been resolved. NOM Insights Reporting is now functioning normally, and reports are loading successfully.

Thank you for your patience.
Posted Apr 28, 2026 - 11:02 UTC

Monitoring

A fix has been implemented for the issue affecting NOM Insights Reporting. Reports are now loading successfully, and we are continuing to monitor the system to ensure stability.

We will provide another update once we have confirmed there is no recurrence of the issue.
Posted Apr 28, 2026 - 09:39 UTC

Investigating

We are currently experiencing an outage affecting NOM Insights Reporting. Reports may begin to load but ultimately fail to complete.

We are actively investigating the issue and will provide updates here as we make progress.
Posted Apr 28, 2026 - 09:18 UTC
This incident affected: Business Areas (Insights).