Degraded EasyPost FedEx shipping performance

Incident Report for NewStore Inc

Resolved

EasyPost has cleared the FedEx shipping incident.
Booking deliveries and creating shipping labels should no longer be impacted.
Posted Nov 25, 2023 - 02:54 UTC

Monitoring

We are monitoring the state of EasyPost FedEx shipping. Please see https://www.easypoststatus.com/ for details.
The reported error rate has declined, but the incident has not been cleared yet.

This may continue to cause issues with booking deliveries and creating shipping labels.
Posted Nov 25, 2023 - 02:02 UTC

Investigating

EasyPost has reposted an incident with FedEx shipping. Please see https://www.easypoststatus.com/ for details.

This may cause issues with booking deliveries and creating shipping labels. In response to this, deliveries will be retried automatically, but can also be retried from within the Associate App.
Posted Nov 25, 2023 - 01:46 UTC
This incident affected: Business areas (Shipping).