UPS API Degradation
Incident Report for NewStore Inc
Resolved
The UPS API errors have subsided, and the service has recovered.

UPS shipping offers can now be retrieved without issue. If you are still running into issues getting shipping offers, please contact NewStore Support.
Posted Jul 25, 2024 - 19:32 UTC
Identified
We now see that the issue has been identified by UPS who is now working on a fix: https://www.easypoststatus.com/incidents/7rhpsrrf37lh

Our advice is still to retry your operation, if you run into an error when trying to retrieve shipping options. Please feel free to contact NewStore Support if you have any questions.
Posted Jul 25, 2024 - 18:10 UTC
Investigating
We have been alerted by EasyPost that UPS API is experiencing some service degradation. If your business uses UPS, this could affect shipping offers for Store Fulfillment or Order Injection.
At this time, our advice is to retry your operation, if you run into an error. Please feel free to contact NewStore Support if you have any questions.

Please also see EasyPost's Status page for more information on this service degradation: https://www.easypoststatus.com/
Posted Jul 25, 2024 - 17:32 UTC
This incident affected: Business areas (Shipping) and Third-Party Integrations (EasyPost API).