The incident is now resolved and all affected NewStore services have been fully restored at this point.
All missing events have now been replayed.
If you notice any missed events there were not replayed please let us know.
Posted Mar 04, 2026 - 16:03 UTC
Update
The services have been restored and the platform has stabilized.
Our team will continue to work on replaying any missing events.
We will update this page once completed.
Posted Mar 04, 2026 - 14:33 UTC
Update
We are continuing to monitor for any further issues.
Posted Mar 04, 2026 - 14:16 UTC
Monitoring
The services have been restored and the platform has stabilized. Engineering is assessing any clean up that may be required due to the incident. If you are using the Associate App in offline mode, you can switch back to online mode.
We are currently monitoring the issue and will provide another update once we have confirmed there is no reoccurrence of the issue.
Posted Mar 04, 2026 - 14:15 UTC
Update
We are seeing stability improving in multiple services, but still recommend for retailers to continue using Offline Mode in the Associate App until all services have recovered. We will provide further updates as more information becomes available.
Posted Mar 04, 2026 - 13:53 UTC
Identified
We have identified the issue and are working to resolve it as soon as possible.
Retailers experiencing issues may use Offline Mode in the Associate App, where available, to continue store operations while the issue is being investigated.
We will provide further updates as more information becomes available.
Posted Mar 04, 2026 - 13:32 UTC
Investigating
We are currently observing elevated error rates across multiple services, which may impact parts of the platform including order management and the Associate App. Our engineering team is actively investigating the issue and working to identify the root cause. We will provide further updates as more information becomes available.
Posted Mar 04, 2026 - 13:24 UTC
This incident affected: NewStore Platform and Business Areas (Checkout, Payments, Returns & Exchanges).