We have deployed a fix to our Customer service endpoint in NOM which has resolved the issue. We apologize for the inconvenience.
Please reach out to NewStore Support if you are still not able to search for Customers in NOM.
Posted Aug 31, 2026 - 18:22 UTC
Investigating
We are currently investigating an issue affecting the Customers section of NewStore Omnichannel Manager (NOM), preventing users from searching for and viewing the customer list.
During this work, when you go to Customers > Customers, searching by customer name or email may return no results, and the full customer list may not load. Individual customer profiles opened by direct link are not affected, and customer search in the Associate App continues to work as normal.
We will share additional information here as soon as it is available.
Posted Aug 31, 2026 - 15:55 UTC
This incident affected: Business Areas (Customer Operations).