Service incident for Insights & Reporting

Incident Report for NewStore Inc

Resolved

The incident with our Insights service is now resolved. We apologize for any delays to Insights or reporting you may have experienced. Reporting now appears to be loading at regular expected times.
Posted Apr 02, 2025 - 18:26 UTC

Investigating

We are currently experiencing an issue with Insights data and reporting. At this time, Insights are either slow to load or not loading at all at the moment. We apologize for the inconvenience.

We are currently investigating this and will provide more information once it becomes available.
Posted Apr 02, 2025 - 15:49 UTC
This incident affected: Business areas (Insights).