EasyPost Degraded FedEx API performance and Degraded UPS Mail Innovations Rating Performance
Incident Report for NewStore Inc
Resolved
The FedEx rating API errors and request timeouts have subsided and the service has recovered.

Please see EasyPost's status page for further information regarding this incident: https://www.easypoststatus.com/
Posted Nov 28, 2023 - 02:44 UTC
Monitoring
The FedEx API has seen an improvement in error rates and we are continuing to monitor the performance.

Please view the current status and updates directly from EasyPost here: https://www.easypoststatus.com/

This may still cause issues with booking deliveries and creating shipping labels. In response to this, deliveries will be retried automatically, but can also be retried from within the Associate App. If you have any persisting issues booking the shipment thru EasyPost, please, be advised that you can book shipments outside of NewStore Platform and update the item status thru NOM if you have this feature enabled.
Posted Nov 27, 2023 - 21:01 UTC
Identified
The FedEx API is experiencing elevated rates of errors and request timeouts for rating. FedEx has been notified and we are still awaiting on Fedex to address the issues with their API performance degradation. We will continue to monitor the situation.

Please view the current status and updates directly from EasyPost here: https://www.easypoststatus.com/

This may cause issues with booking deliveries and creating shipping labels. In response to this, deliveries will be retried automatically, but can also be retried from within the Associate App. If you have any persisting issues booking the shipment thru EasyPost, please, be advised that you can book shipments outside of NewStore Platform and update the item status thru NOM if you have this feature enabled.
Posted Nov 27, 2023 - 19:31 UTC
Update
The FedEx API is experiencing elevated rates of errors and request timeouts for rating. FedEx has been notified and EasyPost engineers will continue to monitor the performance of the API.

Please view the current status and updates directly from EasyPost here: https://www.easypoststatus.com/

This may cause issues with booking deliveries and creating shipping labels. In response to this, deliveries will be retried automatically, but can also be retried from within the Associate App. If you have any persisting issues booking the shipment thru EasyPost, please, be advised that you can book shipments outside of NewStore Platform and update the item status thru NOM if you have this feature enabled.
Posted Nov 27, 2023 - 17:39 UTC
Update
EasyPost's engineers are still investigating the issue with Fedex API, we will continue to monitor the situation.

EasyPost has reported that the UPS Mail Innovations API errors and request timeouts have subsided and the service has recovered.

Please view the current status and updates directly from EasyPost here: https://www.easypoststatus.com/

This may cause issues with booking deliveries and creating shipping labels. In response to this, deliveries will be retried automatically, but can also be retried from within the Associate App. If you have any persisting issues booking the shipment thru EasyPost, please, be advised that you can book shipments outside of NewStore Platform and update the item status thru NOM if you have this feature enabled.
Posted Nov 27, 2023 - 17:15 UTC
Update
We are continuing to investigate this issue.
Posted Nov 27, 2023 - 16:23 UTC
Investigating
We have received reports that EasyPost's API are having issues with performance and availability. Please view the current status and updates directly from EasyPost here: https://www.easypoststatus.com/

This may cause issues with booking deliveries and creating shipping labels. In response to this, deliveries will be retried automatically, but can also be retried from within the Associate App.
Posted Nov 27, 2023 - 16:22 UTC
This incident affected: Third-Party Integrations (EasyPost API).