Adyen increased rate of refusal for Credit Card transactions
Incident Report for NewStore Inc
Resolved
Adyen released a patch to resolve this issue. Since the patch was implemented, refusal rates have normalized, marking the resolution of this issue.
Posted Jan 07, 2025 - 12:23 UTC
Identified
Adyen has identified the issue with Elevated Refusal Rates related to their incident here: https://status.adyen.com/

We will continue to monitor Adyen's incident announcements and update you here.

NewStore Support has already directly contacted affected Retailers, so, if you have not received a Support Case directly from NewStore Support today regarding this incident, you are not affected.
Posted Jan 06, 2025 - 19:36 UTC
Investigating
We have become aware of an issue regarding Payments authorizations that are being reported from Adyen as Successful and later Declined.

We believe this may be related to an incident reported by Adyen here: https://status.adyen.com/

Our Engineering team is currently engaged and investigating and will report back here with more information as soon as possible.
Posted Jan 06, 2025 - 17:14 UTC
This incident affected: NewStore Platform and Business areas (Payments).