EasyPost is experiencing internet connectivity issues and is investigating

Incident Report for NewStore Inc

Resolved

Easypost has not reported any further interruptions. We are setting this incident to resolved.
Posted Jul 23, 2026 - 20:59 UTC

Monitoring

Network connectivity to EasyPost's data centers has been restored, EasyPost reports that services are operating normally, and system-wide error rates have recovered to normal levels.

We are monitoring the situation
Posted Jul 23, 2026 - 19:26 UTC

Update

EasyPost is starting to see improved service connectivity in its primary data center and will continue to monitor as the situation evolves.
Posted Jul 23, 2026 - 18:46 UTC

Identified

A connectivity issue with EasyPost's hosting provider is disrupting EasyPost services. You may see errors or failed requests ("service unavailable") when using the EasyPost API and dashboard.

The hosting provider has confirmed the issue and is actively working to restore connectivity. In parallel, EasyPost is bringing selected services back online through its fallback data center, prioritizing the most critical ones to reduce error rates and restore functionality as quickly as possible.

Because full recovery depends on the hosting provider, there is no estimated restoration time yet.
Posted Jul 23, 2026 - 18:13 UTC

Update

We received an update that Easypost is working with their hosting provider as they investigate connectivity issues to Easypost's primary data center.
Posted Jul 23, 2026 - 16:01 UTC

Update

We are continuing to investigate this issue.
Posted Jul 23, 2026 - 15:51 UTC

Investigating

We have received reports that EasyPost is experiencing an internal networking issue that is impacting all operations. They are still investigating. Please view the current status and updates directly from EasyPost here: https://www.easypoststatus.com/

This may cause issues with booking deliveries and creating shipping labels. In response to this, deliveries will be retried automatically, but can also be retried from within the Associate App.

Alternatively, to get around this, you can book shipment outside of Newstore and update the item status thru NOM.

This issue can also cause the order injections and endless aisle orders to fail, due to the inability to get shipping options. Once Easypost resolves this issue, you can attempt to re-inject orders
Posted Jul 23, 2026 - 15:44 UTC
This incident affected: Third-Party Integrations (EasyPost API).