Delays in Payment Service on May 3rd, 2025

Incident Report for NewStore Inc

Resolved

Our team is still finalizing work on fixing a handful of orders from the incident on Saturday. The work will be completed and communicated through your individual support cases.
Posted May 06, 2025 - 22:01 UTC

Monitoring

We would like to inform you that an incident occurred with our payment service on Saturday, May 3rd ~ 15:35 to 16:25 UTC which could have affected fully placing orders, returns and exchanges.

While our Engineering team resolved the issue on Saturday, they also worked this morning, May 5th, to replay events to help fully place orders with their payments attached.

Most of the payments for affected orders should be now recovered, however, if you do notice any orders that you believe are still unresolved and affected from this timeframe, please open a Support ticket. Our team will investigate and treat them with priority to resolve.

We apologize for the impact and confusion this may have caused your associates and customers. Our team is also working in parallel to study the root cause of this Incident from Saturday and will provide an RCA to your teams in the near future. This will also include more complete details of the timing and impact.
Posted May 05, 2025 - 18:58 UTC
This incident affected: NewStore Platform and Business areas (Payments, Returns & Exchanges).