Adyen have confirmed that checkout services performance has stabilized since April 22 2025, 02:16 CEST. At this point, all payment processing capabilities have returned to normal.
Please see Adyen's status page for further information regarding this incident: https://status.adyen.com/
Posted Apr 22, 2025 - 03:24 UTC
Update
Adyen continue working on recovering services, they stated the following:
"We continue working on recovering Checkout services in EU. Performance for impacted services has started to improve since 01:26 CEST. We will provide a new update in the next hour."
Please see Adyen's status page for further information regarding this incident: https://status.adyen.com/
Posted Apr 21, 2025 - 23:48 UTC
Update
Adyen has provided the following update:
"Checkout services are again experiencing degraded performance since 23:34 CEST.
Checkout customers processing E-commerce transaction through the following integrations are impacted:
Sessions Secure fields Pay by link
We will provide a new update in the next 30 minutes."
Please see Adyen's status page for further information regarding this incident: https://status.adyen.com/
Posted Apr 21, 2025 - 22:08 UTC
Update
Adyen continue to work on resolving the incident, they stated the following:
"We are observing a recovery for the following Checkout services starting at 22:34 CEST: * Session integrations * Secure fields * Pay by link * Alternative payment methods * 3DS Redirect flows We will provide a new update in the next 30 minutes."
Please see Adyen's status page for further information regarding this incident: https://status.adyen.com/
Posted Apr 21, 2025 - 20:46 UTC
Update
Adyen has provided the gollowing update:
"We continue to experience degraded performance for the following Checkout shopper services: * Session integrations * Secure fields * Pay by link * Alternative payment methods * 3DS Redirect flows We continue working on fully re-enabling Checkout shopper on our EU datacenters."
Please see Adyen's status page for further information regarding this incident: https://status.adyen.com/
Posted Apr 21, 2025 - 20:08 UTC
Update
Adyen has provided an update on this issue:
"We are in the process of fully enabling Checkout shopper in EU. The following services are experiencing partial degraded performance: * Alternative payment methods processing * Session integrations * Pay by link"
Please see Adyen's status page for further information regarding this incident: https://status.adyen.com/
Posted Apr 21, 2025 - 19:16 UTC
Identified
Adyen has reported a recurring incident, see below:
"The had experienced a new DDoS attack to EU endpoints starting at 20:35 CEST. Payment processing and other services hosted in EU have recovered since 20:45 CEST. Checkout shopper is currently disabled in EU, which is impacting the following services: * Alternative payment methods processing * Session integrations * Pay by link"
Please see Adyen's status page for further information regarding this incident: https://status.adyen.com/
Posted Apr 21, 2025 - 19:08 UTC
This incident affected: Business Areas (Checkout, Payments, Returns & Exchanges, Payment Service Provider).