We have postponed the maintenance to a later date. We will post a future maintenance window as soon as it's available.
Posted Sep 08, 2025 - 17:19 UTC
Scheduled
We would like to inform you that on September 11th, 2025 between 5am and 12pm UTC, NewStore will undergo an update of its Omnichannel Insights services.
During the maintenance window, Omnichannel Insights and Associate App Store Reporting will be temporarily unavailable.
Any changes a user makes in NOM > Insights > Explore during this time will NOT BE SAVED. For example, updating a dashboards contents, or creating/saving an answer. We ask that you please plan accordingly.
After the update has finished, there will be some slight user interface upgrades. This update will also enhance stability, performance, and security of reporting capabilities.
If you have any questions or concerns, please contact NewStore Support.
Posted Sep 03, 2025 - 13:58 UTC
This scheduled maintenance affected: Business areas (Insights).