EasyPost - LSO API API Service Degradation

Incident Report for NewStore Inc

Resolved

Easypost has stated the issue has been resolved.
Posted Sep 25, 2023 - 20:58 UTC

Update

Easypost is still following up with the carrier that has the degraded performance. The carrier has been notified, and Easypost engineers will continue to monitor the performance of the API.

Please view the current status and updates directly from EasyPost here: https://www.easypoststatus.com/

This may cause issues with booking deliveries and creating shipping labels from certain carriers. In response to this, deliveries will be retried automatically, but can also be retried from within the Associate App.
Posted Sep 25, 2023 - 20:44 UTC

Update

Easypost is still following up with the carrier that has the degraded performance. The situation still being monitored.

Please view the current status and updates directly from EasyPost here: https://www.easypoststatus.com/

Seems that the main carrier seeing the most impacts is with DHL Express. This may cause issues with booking deliveries and creating shipping labels from certain carriers. In response to this, deliveries will be retried automatically, but can also be retried from within the Associate App.
Posted Sep 25, 2023 - 19:15 UTC

Update

The LSO API is still experiencing rates of errors and request timeouts. Easypost is still following up with the carrier that has the degraded performance. The situation still being monitored.

Please view the current status and updates directly from EasyPost here: https://www.easypoststatus.com/

This may cause issues with booking deliveries and creating shipping labels from certain carriers. In response to this, deliveries will be retried automatically, but can also be retried from within the Associate App.
Posted Sep 25, 2023 - 18:12 UTC

Update

The LSO API is still experiencing rates of errors and request timeouts. Easypost has notified the carrier with the degraded performance and still monitoring the situation.

Please view the current status and updates directly from EasyPost here: https://www.easypoststatus.com/

This may cause issues with booking deliveries and creating shipping labels from certain carriers. In response to this, deliveries will be retried automatically, but can also be retried from within the Associate App.
Posted Sep 25, 2023 - 16:48 UTC

Identified

We have received reports that EasyPost's LSO API degraded performance. The LSO API is experiencing elevated rates of errors and request timeouts. Easypost has notified the carrier with the degraded performance. Please view the current status and updates directly from EasyPost here: https://www.easypoststatus.com/

This may cause issues with booking deliveries and creating shipping labels from certain carriers. In response to this, deliveries will be retried automatically, but can also be retried from within the Associate App.
Posted Sep 25, 2023 - 15:42 UTC
This incident affected: Third-Party Integrations (EasyPost API).