Degraded performance related to Event Stream

Incident Report for NewStore Inc

Resolved

The event stream service has been stabilized and is now processing events normally. All delayed events have been fully emitted, and order related event processing has returned to expected performance. If you experience any further problems, please reach out to NewStore Support.
Posted Aug 24, 2025 - 10:11 UTC

Monitoring

The situation has improved and the event stream is steadily processing, though some delays may persist until all events have been fully emitted. We will provide another update once processing has fully normalized.
Posted Aug 23, 2025 - 23:48 UTC

Update

We are continuing to work on stabilizing event processing. In the meantime, you may notice delays in order-related events. All events will be processed once the event-stream service is stable. We will share additional updates here as soon as they are available.
Posted Aug 23, 2025 - 20:52 UTC

Identified

We have identified an issue affecting event publishing on the NewStore Platform. This has the potential to impact any event stream that is listening to NewStore Platform events. We will share additional information here as soon as it is available.
Posted Aug 23, 2025 - 19:22 UTC
This incident affected: Business areas (Event Stream).