Service degradation related to Event Stream
Incident Report for NewStore Inc
Resolved
The incident is now resolved and our Engineering teams has confirmed that all events have been replayed and GraphQL is now updated.

Consequently, the GraphQL orders data now includes the previously missing demand location ID.

Should you encounter any issues with your orders or have any questions, please don't hesitate to contact NewStore Support for assistance.

Thank you for your patience during this incident.
Posted Dec 14, 2023 - 09:46 UTC
Update
While we have fixed the root cause of the missing "demand_location_id" attribute in our platform for newly created events, our team is still working on replaying past events with the corrected data. This, in turn, is expected to correct GraphQL query responses.

We would like to inform you that all the "sales_order.captured" events have already been replayed. At present, our team is actively working on replaying all the other effected order events. The size and volume of events causes us to change our estimate for the completion. At this moment we expect all events to be replayed by the end of the US business day. We will continue to provide updates on our progress.

We apologize for the impact that this is having on your integrations. Please be assured that no data was lost, and we are dedicated to correcting the data as soon as possible.
Posted Dec 13, 2023 - 15:58 UTC
Update
While we have fixed the root cause of the missing "demand_location_id" attribute in our platform for newly created events, our team is still working on replaying past events with the corrected data. This, in turn, is expected to correct GraphQL query responses.

We would like to inform you that all the "sales_order.captured" events have already been replayed. At present, our team is actively working on replaying all the other effected order events. We will continue to provide updates on our progress.

We apologize for the impact that this is having on your integrations. Please be assured that no data was lost, and we are dedicated to correcting the data as soon as possible.
Posted Dec 13, 2023 - 10:32 UTC
Update
While we have fixed the root cause of the missing "demand_location_id" attribute in our platform for newly created events, our team is still working on replaying past events with the corrected data. This, in turn, is expected to correct GraphQL query responses.

Unfortunately, we expect this batch processing of past events to continue into tomorrow (Eastern Standard Time), but we will continue to provide updates on our progress. We apologize for the impact that this is having on your integrations. Please be assured that no data was lost, and we are dedicated to correct the data as soon as possible.
Posted Dec 13, 2023 - 00:34 UTC
Update
We still monitoring the platform and our engineering team continues to work on fixing the data for orders impacted by this incident. We will provide another update once we have confirmed that all the orders impacted have been fixed.
Posted Dec 12, 2023 - 20:38 UTC
Update
We continue to actively monitoring the platform. All new orders will have the demand Location ID field populated in GraphQl and our team continues to work on fixing the data for orders impacted by this incident. We will provide another update once we have confirmed that all the orders impacted have been fixed.
Posted Dec 12, 2023 - 16:24 UTC
Monitoring
We have a fix in place and are actively monitoring the platform. All new orders will have the demand Location ID field populated in GraphQl and our team is working on fixing the data for orders impacted by this incident. We will provide another update once we have confirmed that all the orders impacted have been fixed.
Posted Dec 12, 2023 - 12:58 UTC
Identified
We have identified the cause of the issue with GraphQl and are currently working on a solution. We apologize for any inconvenience this causes and will continue to share additional information here as soon as it is available.
Posted Dec 12, 2023 - 12:42 UTC
Investigating
We are currently investigating a possible issue with the Event Stream. This has the potential to impact GraphQl where the demand Location Id field is appearing as null for orders

We will share additional information here as soon as it is available.
Posted Dec 12, 2023 - 12:27 UTC
This incident affected: Business areas (Fulfillment).