Partial Outage related to Order Routing
Incident Report for NewStore Inc
Resolved
The incident is now resolved and all affected NewStore services have been fully restored at this point. All orders now should have been routed from our replay of events. The team will continue to monitor and fully investigate the root cause. If you are still seeing signs of orders not routing as expected, please contact Support. Thank you for your patience during this incident.
Posted Mar 23, 2023 - 18:52 UTC
Monitoring
We have a possible fix in place and are actively monitoring the platform. At this point in time, newer orders should now be routing as expected or will be routing as expected very soon. For orders that were stuck OnHold or Pending during this Incident, please expect to wait a little longer while we replay all paused events. We will provide another update once we have replayed all events and confirmed there is no reoccurrence of the issue.
Posted Mar 23, 2023 - 18:30 UTC
Identified
We have identified the cause of the issue with Order Routing. We have multiple resources from our Engineering team engaged and actively working on a solution. At this time, we believe Order Injection is working as expected and that this is only affecting Orders Routing in the platform. We apologize for any inconvenience this causes and will continue to share additional information here as soon as it is available.
Posted Mar 23, 2023 - 17:43 UTC
Investigating
We are currently investigating a possible issue with Order Routing. This has the potential to impact Orders transitioning from Pending to Routing and Order re-routing from OnHold. We will share additional information here as soon as it is available.
Posted Mar 23, 2023 - 17:23 UTC
This incident affected: NewStore Platform and Business areas (Routing).