We apologize for any inconvenience this may have caused your business. Please reach out to NewStore Support if you see the issue reoccur again.
Posted Aug 03, 2026 - 16:49 UTC
Monitoring
We have implemented a more stable fix and will continue to monitor the platform.
At this time you should be seeing successful page loading in NOM.
Posted Aug 03, 2026 - 16:06 UTC
Identified
We are still seeing issues with NOM loading inconsistently. We are working to provide a more stable fix and hope to update you again soon.
Posted Aug 03, 2026 - 14:29 UTC
Monitoring
A fix has been implemented, and we are monitoring the results.
Please contact NewStore Support if you are still seeing issues loading pages in NOM.
Posted Aug 03, 2026 - 14:16 UTC
Investigating
We are currently investigating a possible issue with NOM dashboards. This has the potential to impact the Orders page in NOM as well as other pages not loading.
We will share additional information here as soon as it is available.
Posted Aug 03, 2026 - 13:53 UTC
This incident affected: Business Areas (Omnichannel Manager).