Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 23, 2026 - 04:30 UTC
Scheduled
NewStore will perform a scheduled upgrade of the production IAM system, including the login service, to improve the platform’s security, stability, and performance.
Maintenance window: - Wednesday, September 23, 2026, from 4:30 AM to 5:00 AM UTC.
Affected component: - IAM (Login)
Impact Description: - NOM and Associate App password logins as well as token operations can experience a short interruption. In some cases the PIN login on the Associate App might be invalidated resulting in the users to perform a username/password based authentication and set a new PIN.
Required preparation: - No preparation or action is required.
Please reach out to NewStore Support if you have any questions.
Posted Sep 15, 2026 - 15:57 UTC
This scheduled maintenance affected: NewStore Platform and Business Areas (Omnichannel Manager).