AWS ongoing incident affecting various parts of NewStore platform.

Incident Report for NewStore Inc

Resolved

The underlying infrastructure incident has be resolved by AWS. We are setting this incident here to resolved as well. All NewStore services are up and running. If you experience any anomalies please do not hesitate to contact our Support team at help.newstore.com
Posted Oct 20, 2025 - 23:26 UTC

Update

Our infrastructure provider AWS has provided further positive updates in their latest updates. We are continuing to monitor our services, at this moment everything appears to be back to a normal state.
Should you still experience issues with any of the NewStore Omnichannel platform services, please do not hesitate to create a support ticket at help.newstore.com
Posted Oct 20, 2025 - 21:26 UTC

Update

The error rates we saw on the AWS infrastructure have significantly improved and we are monitoring closely if the incident is resolved.
We will update this page as soon as we have more information.
Posted Oct 20, 2025 - 20:12 UTC

Update

We received an update from our infrastructure provider, AWS that indicated an improvement, though not a full recovery of all services used by the NewStore Omnichannel platform. This means that we still expect irregular instabilities for all services including the Associate App, NOM and order injections
We will update this page again when we have additional information.
Posted Oct 20, 2025 - 19:25 UTC

Update

We are continuing to see networking related issues impacting some of our services. AWS has made progress but not all services are recovered, yet. https://health.aws.amazon.com/health/status
Unfortunately you can still expect sporadic error messages in all services including the Associate App, NOM and order injection.
Posted Oct 20, 2025 - 17:48 UTC

Update

Our infrastructure provider informed us that they improved stability, we are monitoring closely and will update this page when we have additional information.
Posted Oct 20, 2025 - 17:00 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 16:31 UTC

Update

We are seeing some services being impacted again by the underlying infrastructure provider incident. We will update this page once we have more details about the impact.
Posted Oct 20, 2025 - 16:22 UTC

Update

All NewStore services are now fully recovered. Please proceed with eCom orders injection and offline orders submission.

Please note that an additional action may still be required to resume Adyen webhook notifications. If applicable, log into your Adyen Dashboard and manually resume webhook notifications. Detailed troubleshooting steps are available here:
https://docs.adyen.com/development-resources/webhooks/troubleshoot/

We will continue to monitor the platform and complete remaining cleanup activities.
Posted Oct 20, 2025 - 11:27 UTC

Monitoring

AWS has reported that the issue has been resolved. You can view the latest AWS status here: https://health.aws.amazon.com/health/status

Our engineering team has confirmed that the NewStore platform has largely recovered, and Associate App users may now resume Online Mode.

However, we are still working on restoring eCom order injection and Offline order submission, and will provide updates on these items as progress continues.

Please note that an additional action may be required to restore Adyen webhook notifications. If applicable, log into your Adyen Dashboard and manually resume webhook notifications to ensure full processing continues. Detailed troubleshooting steps are available here: https://docs.adyen.com/development-resources/webhooks/troubleshoot/

We will continue to monitor the situation and are performing cleanup activities. If you experience any further issues, please contact NewStore Support.

Thank you for your patience throughout this incident.
Posted Oct 20, 2025 - 10:58 UTC

Identified

AWS has reported that initial mitigations have been applied, and early signs of recovery are being observed across impacted services.

We are also seeing gradual improvements within NewStore systems. Some functionality may still be limited while AWS continues its recovery efforts.

Our teams are closely monitoring the situation and will provide further updates as additional progress is made. Thank you for your continued patience and understanding.
Posted Oct 20, 2025 - 09:38 UTC

Update

The ongoing AWS outage continues to affect NewStore services. In addition to the current disruptions, support ticket creation may also be impacted, as our ticketing tool appears to be affected by the same outage.

Please continue using Offline Mode for the Associate App where applicable. We will share further updates as soon as AWS provides additional information.

Thank you for your continued patience.
Posted Oct 20, 2025 - 08:27 UTC

Investigating

We are currently experiencing an ongoing AWS outage (https://health.aws.amazon.com/health/status) that is affecting NewStore. Several functionalities, including login, are impacted at this time. Our team is actively assessing the situation, and we will provide further updates as soon as more information becomes available.

For now, all Associate App users are advised to switch to Offline Mode until further notice.
Posted Oct 20, 2025 - 07:33 UTC
This incident affected: NewStore Platform.