Service degradation for Associate App order checkout and payment

Incident Report for NewStore Inc

Resolved

The incident has been fully resolved, and all affected NewStore services have been restored.

We apologize for the disruption and any confusion this may have caused your associates and customers. Our team will continue to monitor the platform and conduct a thorough investigation into the root cause.
Posted Jul 31, 2025 - 14:21 UTC

Monitoring

We have implemented a fix and are actively monitoring the platform. The issue had been causing slowness in the Associate App, including during order checkout and payment processing, and order injection. All affected services are now operating normally. We will provide another update once we have confirmed the issue has been fully resolved and there is no recurrence.
Posted Jul 31, 2025 - 12:00 UTC

Update

We are continuing to investigate this issue.
Posted Jul 31, 2025 - 11:52 UTC

Investigating

We are currently investigating a possible issue with our Newstore platform. This has the potential to impact slowness in order checkout and payment processing via the Associate App. We will share additional information here as soon as it is available.
Posted Jul 31, 2025 - 11:39 UTC
This incident affected: Business areas (Checkout, Payments).