Adyen Payment Degraded Performance in EU

Incident Report for NewStore Inc

Resolved

We have received notification from Adyen that they have full recovery:
"Checkout shopper has now been fully enabled in EU. Alternative payment methods processing and Session integrations have fully recovered since.

This incident is considered resolved. We will continue monitoring and provide a new update if require"

Please see Adyen's status page for further information regarding this incident: https://status.adyen.com/
Posted Apr 21, 2025 - 18:40 UTC

Update

We have received the following information from Adyen:

"Payment processing in EU has fully recovered since 19:39 CEST.

This includes customers connecting to EU endpoints while based in other regions, and/or connecting to other regions processing payments through acquirers and payment methods connected through our EU datacenters.

Checkout shopper services have been partially enabled in EU. Impact to Alternative payment methods processing and Session integrations has partially recovered since."

We continue to monitor the situation and will share further updates soon.

Please also see Adyen's Status page for more information on this service degradation: https://status.adyen.com/
Posted Apr 21, 2025 - 18:26 UTC

Update

We have received the following information from Adyen:

"Payment processing in EU has fully recovered since 19:39 CET.

Other services hosted in EU datacenters including Customer Area, onboarding and transfers have also recovered since.

Checkout shopper services in EU are currently being re-enabled. Customer might be experiencing degraded performance in processing Alternative payment methods (APM) and Session integrations."

We continue to monitor the situation and will share further updates soon.

Please also see Adyen's Status page for more information on this service degradation: https://status.adyen.com/
Posted Apr 21, 2025 - 18:09 UTC

Identified

Adyen has reported that there is an issue impacting the performance of one or more of our services in Europe.

The vendor has stated this is caused by a DDOS attack on their EU endpoints. As a result, customers connecting to EU endpoints are experiencing an elevated number of errors and elevated response time. We will share further updates soon.

Please also see Adyen's Status page for more information on this service degradation: https://status.adyen.com/
Posted Apr 21, 2025 - 17:39 UTC
This incident affected: Business areas (Checkout, Payments, Returns & Exchanges, Payment Service Provider).