Service Degradation for External Order Service API

Incident Report for NewStore Inc

Update

We are currently estimating that the backfill of data for this API service will be completed sometime tomorrow, 14th of March. We will update you again if this estimate changes or, otherwise, once completed.
Posted Mar 13, 2026 - 18:26 UTC

Update

Our team is continuing to work on backfilling the missing data. The process is still in progress, and we are actively monitoring it. We will provide another update here once the backfill has been completed.
Posted Mar 13, 2026 - 09:05 UTC

Monitoring

Our team is continuing to work on backfilling the missing data. We will update here once completed.
Posted Mar 12, 2026 - 20:33 UTC

Update

We have identified all orders that were impacted that have incomplete or missing data when calling the External Order API.

We will replay the missing data to the service and let you know once completed.
Posted Mar 12, 2026 - 18:26 UTC

Identified

We have identified the issue which affected the External Order service and are now working on resolving.

It's important to note that this is not affecting new orders being created, and they are fully available through this External Order API service. There is only a small subset of orders that might have missing or incomplete data when using the API which we are looking to resolve.

We will continue to keep you updated here with progress.
Posted Mar 12, 2026 - 17:11 UTC

Investigating

We are currently investigating an issue with our External Order Service API: /v0/d/external_customers/email/{email}/orders returning incomplete Order data.

This has the potential to impact any integrations that have implemented this API.

If you have any questions as to whether you are impacted, please contact your SI Partner or who manages your integrations.

We will provide more information as we continue to investigate.
Posted Mar 12, 2026 - 16:32 UTC
This incident affects: NewStore Platform.