EasyPost API Degradation
Incident Report for NewStore Inc
Resolved
EasyPost has stated this incident is now resolved.

See Easypost status page for more details:
https://www.easypoststatus.com/
Posted Jul 16, 2024 - 23:09 UTC
Monitoring
We have received reports that Easypost API experienced an increase in API error rate between 13:52 and 14:31 PST.
Error rates have returned to normal and they are continuing to monitor API performance. Users should attempt to retry failed API calls.

See Easypost status page for more details:
https://www.easypoststatus.com/
Posted Jul 16, 2024 - 22:20 UTC
This incident affected: Third-Party Integrations (EasyPost API).