EasyPost API Degradation

Incident Report for NewStore Inc

Resolved

The EasyPost incident is now resolved and all affected NewStore services should now be fully restored.
Posted Sep 25, 2023 - 20:56 UTC

Monitoring

Easypost has reported, the API availability has returned to normal. Easypost engineers are continuing to monitor this situation

Please view the current status and updates directly from EasyPost here: https://www.easypoststatus.com/

There might be issues with booking deliveries and creating shipping labels while we monitor the situation. In response to this, deliveries will be retried automatically, but can also be retried from within the Associate App.
Posted Sep 25, 2023 - 20:20 UTC

Identified

We have received from Easypost that the issue has been identified, their engineers are continuing to monitor as the API is returning to a working order state.

Please view the current status and updates directly from EasyPost here: https://www.easypoststatus.com/

This may still cause some issues with booking deliveries and creating shipping labels. In response to this, deliveries will be retried automatically, but can also be retried from within the Associate App.
Posted Sep 25, 2023 - 19:45 UTC

Investigating

We have received reports that EasyPost's API are having issues with performance and availability. Please view the current status and updates directly from EasyPost here: https://www.easypoststatus.com/

This may cause issues with booking deliveries and creating shipping labels. In response to this, deliveries will be retried automatically, but can also be retried from within the Associate App.
Posted Sep 25, 2023 - 19:30 UTC
This incident affected: Third-Party Integrations (EasyPost API).