Orders stuck in Pending
Incident Report for NewStore Inc
Resolved
This incident has been resolved.
Posted Oct 03, 2024 - 23:46 UTC
Monitoring
We have noticed an uptick in orders stuck in Pending for the past several hours. We are currently scaling up our resources and monitoring the issue. You may see an increased number of orders in Pending, but they should start to reduce soon.

We will update you once we have confirmed that systems are working again as expected.
Posted Oct 03, 2024 - 20:37 UTC
This incident affected: NewStore Platform and Business areas (Routing).