EasyPost Degraded UPS API Performance causing API Rate Limiting error

Incident Report for NewStore Inc

Resolved

The issue was resolved on the downstream systems.
Posted Dec 02, 2025 - 21:21 UTC

Update

While there has not been an official statement from UPS or EasyPost, we have verified that the our services have not see any further error messages regarding the rate limitation.
At this moment we expect all functionality in the Associate App or in NOM to work without issue, but we will continue to monitor updates from the downstream services.
Posted Dec 02, 2025 - 19:40 UTC

Update

We are continuing to monitor the UPS API rate limitation. We have not received any further details form EasyPost or UPS, but will update this page as soon as something is changing.
Posted Dec 02, 2025 - 19:23 UTC

Monitoring

We have received reports that EasyPost's API are having issues with performance and availability. Please view the current status and updates directly from EasyPost here: https://www.easypoststatus.com/

UPS shipments (rating) may be experiencing delays or errors due to API rate limitations on UPS's side. Easypost is working directly with UPS to resolve this issue.

The order will show onhold for the following error Carrier Service Delivery Problem. Check the Shipping Option Reports feature in NOM under the Tools tab on the right hand side of the NOM directory. If you receive a 'Too Many Requests' error it is most likely related to this problem.

If you have a reroute mechanism, there rerouting feature will retrigger the order routing otherwise try the handle exception button to reroute the order.
Posted Dec 02, 2025 - 16:19 UTC
This incident affected: Third-Party Integrations (EasyPost API).