UPS API Degredation
Incident Report for NewStore Inc
Resolved
The UPS API has stabilized.
Posted Nov 29, 2023 - 20:06 UTC
Monitoring
Error rates from the UPS API have returned to normal. We are monitoring their performance.
Posted Nov 29, 2023 - 18:44 UTC
Investigating
We have been alerted by EasyPost that UPS API is experiencing some service degradation for labels and ratings. If your business uses UPS, this could affect shipping offers for Store Fulfillment or Order Injection.
At this time, our advice is to retry your operation, if you run into an error. Please feel free to contact NewStore Support if you have any questions.

Please also see EasyPost's Status page for more information on this service degradation: https://www.easypoststatus.com/
Posted Nov 29, 2023 - 17:57 UTC
This incident affected: Business areas (Shipping).