Degraded EasyPost FedEx shipping performance

Incident Report for NewStore Inc

Resolved

According to EasyPost, the FedEx rating API errors and request timeouts have subsided, and the service has recovered. https://www.easypoststatus.com/incidents/27stzblxp962
Posted Nov 25, 2023 - 00:44 UTC

Monitoring

EasyPost informed us that the number of timeouts has decreased, but the incident is not fully resolved.
Posted Nov 24, 2023 - 22:07 UTC

Update

We are continuing to monitor the situation with the elevated error rates and timeouts in EasyPost for FedEx shipments.
This could lead to errors when processing shipments in Omnichannel. Please check https://www.easypoststatus.com/incidents/27stzblxp962 for more details on the incident.
Posted Nov 24, 2023 - 19:36 UTC

Investigating

We are currently investigating a possible issue with EasyPost FedEx shipments. Please also see https://www.easypoststatus.com/
Posted Nov 24, 2023 - 18:35 UTC
This incident affected: Business areas (Shipping).